Re-registering a custom post type not working (not showing up)

I registered a custom post type, but then I changed register_post_type( ‘studentenverenigingen’, $args ); into register_post_type( ‘studentenverenigingen’, $args ); . Now my client wants it back to the first one, so I changed it, but somehow it’s not working now.

I don’t see it in the admin bar and also the archive / url isn’t visible either.

Who can tell me what is wrong with this:

$labels = array(
‘name’ => _x( ‘Studentenverenigingen’, ‘Post Type General Name’, ‘text_domain’ ),
‘singular_name’ => _x( ‘Studentenvereniging’, ‘Post Type Singular Name’, ‘text_domain’ ),
‘menu_name’ => __( ‘VERENIGINGEN’, ‘text_domain’ ),
‘name_admin_bar’ => __( ‘Studentenverenigingen’, ‘text_domain’ ),
‘archives’ => __( ‘Item Archives’, ‘text_domain’ ),
‘attributes’ => __( ‘Item Attributes’, ‘text_domain’ ),
‘parent_item_colon’ => __( ‘Huidige Opleiding:’, ‘text_domain’ ),
‘all_items’ => __( ‘Alle Studentenverenigingen’, ‘text_domain’ ),
‘add_new_item’ => __( ‘Studentenvereniging toevoegen’, ‘text_domain’ ),
‘add_new’ => __( ‘Studentenvereniging toevoegen’, ‘text_domain’ ),
‘new_item’ => __( ‘New Item’, ‘text_domain’ ),
‘edit_item’ => __( ‘Studentenvereniging aanpassen’, ‘text_domain’ ),
‘update_item’ => __( ‘Studentenvereniging updaten’, ‘text_domain’ ),
‘view_item’ => __( ‘Bekijk Studentenvereniging’, ‘text_domain’ ),
‘view_items’ => __( ‘Studentenverenigingen bekijken’, ‘text_domain’ ),
‘search_items’ => __( ‘Zoek een studentenvereniging’, ‘text_domain’ ),
‘not_found’ => __( ‘Geen studentenvereniging gevonden’, ‘text_domain’ ),
‘not_found_in_trash’ => __( ‘Geen studentenvereniging gevonden in prullenbak’, ‘text_domain’ ),
‘featured_image’ => __( ‘Featured Image’, ‘text_domain’ ),
‘set_featured_image’ => __( ‘Set featured image’, ‘text_domain’ ),
‘remove_featured_image’ => __( ‘Remove featured image’, ‘text_domain’ ),
‘use_featured_image’ => __( ‘Use as featured image’, ‘text_domain’ ),
‘insert_into_item’ => __( ‘Insert into item’, ‘text_domain’ ),
‘uploaded_to_this_item’ => __( ‘Uploaded to this item’, ‘text_domain’ ),
‘items_list’ => __( ‘Items list’, ‘text_domain’ ),
‘items_list_navigation’ => __( ‘Items list navigation’, ‘text_domain’ ),
‘filter_items_list’ => __( ‘Filter items list’, ‘text_domain’ ),
); $args = array(
‘label’ => __( ‘Studentenvereniging’, ‘text_domain’ ),
‘description’ => __( ‘Studentenverenigingen informatie pagina’, ‘text_domain’ ),
‘labels’ => $labels,
‘supports’ => array( ‘title’, ‘editor’, ‘thumbnail’, ‘comments’, ‘custom-fields’ ),
‘taxonomies’ => array( ‘category’, ‘post_tag’ ),
‘hierarchical’ => false,
‘public’ => true,
‘show_ui’ => true,
‘show_in_menu’ => true,
‘menu_position’ => 8,
‘show_in_admin_bar’ => true,
‘show_in_nav_menus’ => true,
‘can_export’ => true,
‘has_archive’ => true,
‘exclude_from_search’ => false,
‘publicly_queryable’ => true,
‘query_var’ => ‘studentenverenigingen’,
‘capability_type’ => ‘page’,
);
register_post_type( ‘studentenverenigingen’, $args );

Read more here:: Re-registering a custom post type not working (not showing up)

Leave a Reply

Your email address will not be published. Required fields are marked *